Auomatisierung funktioniert nur per manueller Auslösung

Forum Forum Automatisierungen Auomatisierung funktioniert nur per manueller Auslösung

Schlagwörter: , ,

Ansicht von 9 Antwort-Themen
  • Autor
    Beiträge
    • #2948
      AndreasD
      Teilnehmer

      Hallo,

      bei mir klemmt es mal wieder beim Verständnis. Ich habe folgende Automatisierung erstellt:

      Wenn die Pumpe an ist und

      der Wert des Feuchtigkeitssensors unter 600 geht (sinkt, wenn er nass wird), dann

      schalte die Pumpe aus

      alias: Füllhöhe erreicht
      description: “
      trigger:
      – type: value
      platform: device
      device_id: cf2fd7373bd5781dcb04920821844ef5
      entity_id: sensor.tasmota_analog_a0
      domain: sensor
      below: 600
      condition:
      – condition: and
      conditions:
      – condition: state
      entity_id: switch.tasmota5
      state: ‚On‘
      action:
      – type: turn_off
      device_id: 20398c1ff1e5a3c35238c8b4113f1c97
      entity_id: switch.tasmota5
      domain: switch
      mode: single

      Wenn ich die Pumpe an habe und die Automation mit „Aktion ausführen“ starte, funktioniert es. Wenn ich allerdings den Sensor ins Wasser halte, geht der Wert zwar auf 339 zurück, aber die Pumpe bleibt eingeschalten.

      Woran kann das liegen?

      Beste Grüße, Andreas

      PS: über die Schaltfläche ‚Code‘, konnte ich ihn nicht einstellen.

       

       

    • #2950
      AndreasD
      Teilnehmer

      Scheint so, als habe ich es gelöst. Ich habe den Trigger geändert und nun funktioniert es. Aber warum muss ich da eine Zeit eingeben? Hier diese 2 Sekunden.

      alias: Füllhöhe erreicht
      description: “
      trigger:
      – platform: numeric_state
      entity_id: sensor.tasmotawasserstand_analog_a0
      below: ‚600‘
      condition:
      – condition: and
      conditions:
      – condition: device
      type: is_on
      device_id: 20398c1ff1e5a3c35238c8b4113f1c97
      entity_id: switch.tasmota5
      domain: switch
      for:
      hours: 0
      minutes: 0
      seconds: 2
      milliseconds: 0
      action:
      – type: turn_off
      device_id: 20398c1ff1e5a3c35238c8b4113f1c97
      entity_id: switch.tasmota5
      domain: switch
      mode: single

       

      Gruß, Andreas

    • #2951
      jim
      Teilnehmer

      Moin Andreas,

      ob das jetzt auf Dein Problem zutrifft weiß ich nicht, aber mal ganz allgemein als Info von jemanden der auch gerade seine ersten Gehversuche mit HA macht. 🙂

      Du schreibst: „Wenn ich allerdings den Sensor ins Wasser halte, geht der Wert zwar auf 339 zurück, aber die Pumpe bleibt eingeschalten.“

      Du hast aber schon daran gedacht das HA nicht sofort auf den jeweiligen Zustand des Sensors reagiert, sondern erst dann wieder wenn HA den Zustand über die entsprechende Entität erneut abfragt. Ich kann Dir allerdings nicht sagen nach welchem Intervall (Sekunden/Minuten) das standardmäßig erfolgt. Als HA-Anfänger war mir das bei meiner ersten Automation per Tasmota Steckdose zum laden des Akkus meines MediaPad Tablets aufgefallen.

      Automation: Lade den Akku wenn die Ladung unter  25 % fällt:

      <code class="language-markup-templating">alias: MediaPad Akku 25 %
      description: ''
      trigger:
        - type: battery_level
          platform: device
          device_id: e260aa5ce0082fe084bfd6117dd70e91
          entity_id: sensor.bah_w09_akkufullstand
          domain: sensor
          below: 25
      condition: []
      action:
        - type: turn_on
          device_id: 3305d963131ca6ce2d23a072d951575b
          entity_id: switch.tasmota
          domain: switch
      mode: single

      Automation: Stoppe das laden wenn der Akku 80 % hat:

      <code class="language-markup-templating">alias: MediaPad Akku 80%
      description: ''
      trigger:
        - type: battery_level
          platform: device
          device_id: e260aa5ce0082fe084bfd6117dd70e91
          entity_id: sensor.bah_w09_akkufullstand
          domain: sensor
          above: 80
      condition: []
      action:
        - type: turn_off
          device_id: 3305d963131ca6ce2d23a072d951575b
          entity_id: switch.tasmota
          domain: switch
      mode: single

      Zu Anfang stand ich auch ganz gespannt dabei 🙂 und habe darauf gewartet das die Tasmota Steckdose schaltet sobald 25 oder 80 % erreicht sind. Zwischen erreichen des Wertes und schalten der Steckdose, vergingen bzw. vergehen dann aber x Sekunden/Minuten bis HA die Entität „sensor.bah_w09_akkufullstand“ wieder regulär abgefragt hatte. D.h. der Akku hat dann schon 80 + x % bevor die Tasmota Steckdose wieder abgeschaltet wird.

      VG Jim

      • Diese Antwort wurde geändert vor 2 Wochen, 4 Tage von jim.
    • #2954
      AndreasD
      Teilnehmer

      Hallo Jim,

      Danke für die Antwort. Das mit der Zeit hatte ich bedacht. Im Tasmota war unter Telemetrieperiode 60 Sekunden eingestellt. Ich habe einige Minuten gewartet. 60 Sekunden waren eh zu lange, dann wäre mein Wasserfass schon komplett übergelaufen. Aber selbst das Zurückstellen auf 10 Sekunden hat in der oberen Automation nicht funktioniert.

      Gruß, Andreas

    • #2955
      speedyhb
      Teilnehmer

      Hallo Zusammen,

      da habe ich als Anfänger bei HA auch nochmal meine Erfahrungen/Fragen.

      Ich mach die Automation immer übers Menue. Als Mode nehme ich immer single und als letzten Befehl setze ich immer : „warten auf Auslöser“.

      Ich bin mir aber nicht sicher, ob das wirklich so richtig ist, da ich die verschiedenen Möglichkeiten bei „mode“ noch nicht vestanden haeb.

      Aber so haben bis her alle Automationen geklappt, wenn ich den „warten auf Auslöser“ nicht mit drin hatte, ging es nicht immer.

      Vielleicht habt Ihr ja eine Idee hierzu ?

      Gruss

      Speedy

    • #2956
      jim
      Teilnehmer

      @AndreasD

      Ah ok verstanden. Aber jetzt geht das wohl in eine „Tiefe“ in der ich nicht mehr folgen kann. 🙂

      Nur noch eine Anmerkung. Du hast also die Tasmota Telemetry period bei der Steckdose reduziert?
      Tasmota_Logging_Parameter

      Oder geht es um den Feuchtigkeitssensor? Der muss ja den aktuellen Zustand melden.

      Du wirst Tasmota ja wahrscheinlich auch per MQTT eingebunden haben. Da gibt es auch z.B. scan_interval und force_update was m.W. für HA relevant ist. Aber da bin ich jetzt raus. 🙂

      VG Jim

      • Diese Antwort wurde geändert vor 2 Wochen, 4 Tage von jim.
      • Diese Antwort wurde geändert vor 2 Wochen, 4 Tage von jim.
    • #3021
      AndreasD
      Teilnehmer

      @jim

      Nur noch eine Anmerkung. Du hast also die Tasmota Telemetry period bei der Steckdose reduziert?

      ja, habe ich. Aus welchem Grund auch immer, es funktioniert jetzt.

      Wie ich etwas direkt über MQTT ansteuern kann, würde mich echt interessieren. Aber wie das geht, keine Ahnung. Muss ich da auch eine yaml schreiben oder was genau?

      Gruß, Andreas

    • #3027
      jim
      Teilnehmer

      Was die MQTT Parameter betrifft siehe hier (Lösung = letztes Posting): https://community.home-assistant.io/t/change-scan-interval-for-mqtt-sensor/22851/11

      Ob das funktioniert habe ich aber nicht getestet.

      VG Jim

    • #3031
      AndreasD
      Teilnehmer

      Danke für die Info jim. Recht interessant die Seite. Worüber ich aber schon bei einer einfachen MQTT-Konfiguration bei Tasmota (siehe Sreenshot) stolpere sind die Begriffe ’state_topic‘ und value_template von „deiner“ Seite.

      Weißt Du, was ich sinnvolles in meinem Beispiel unter „client“, „topic“ und „full topic“ eintrage?

      Vielleicht auch im Zusammenhang mit mehreren Steckdosen.

      Gruß, Andreas

    • #3032
      jim
      Teilnehmer

      Nein, dazu müsste ich mich auch erst weiter in das Thema einlesen. Also z.B. hier:
      https://forum.creationx.de/lexicon/index.php?entry/37-mqtt-eine-einf%C3%BChrung/
      https://tasmota.github.io/docs/MQTT/
      https://tasmota.github.io/docs/Commands/
      usw.

      Bisher gab es für mich dazu aber noch keine Notwendigkeit, sodass ich da noch nicht so tief eingestiegen bin. 🙂

      VG Jim

       

       

Ansicht von 9 Antwort-Themen
  • Du musst angemeldet sein, um auf dieses Thema antworten zu können.