AVM FRITZ!Box Net Monitor

Forum Forum Schnelle Frage AVM FRITZ!Box Net Monitor

Ansicht von 12 Antwort-Themen
  • Autor
    Beiträge
    • #1689
      butzibutz
      Teilnehmer

      Guten Morgen Zusammen,

      ich habe gestern folgende Integration AVM FRITZ!Box Net Monitor (https://www.home-assistant.io/integrations/fritzbox_netmonitor/) im Home Assistant integriert.

      Die Daten werden mir auch angezeigt:

      FirtzBox

      In der configuration.yaml steht folgender Code:

      <code class="language-markup-templating"># FritzBox Netmonitor
        - platform: fritzbox_netmonitor
          name: FritzBox Netzwerk Monitor
          host: 192.x.x.x

      Die Kachel baue ich mit folgendem Code:

      <code class="language-markup-templating">type: vertical-stack
      cards:
        - type: picture
          image: local/images/fritzbox.png
          hold_action:
            action: none
        - type: horizontal-stack
          cards:
            - type: entity
              entity: sensor.fritzbox_netzwerk_monitor
              name: Online Status
            - type: entity
              entity: sensor.fritzbox_netzwerk_monitor
              attribute: external_ip
              name: Externe IP
              icon: 'mdi:ip'
        - type: entity
          entity: sensor.fritzbox_netzwerk_monitor
          attribute: transmission_rate_down
          name: Transmission rate down
          icon: 'mdi:cloud-download'
        - type: entity
          entity: sensor.fritzbox_netzwerk_monitor
          attribute: transmission_rate_up
          name: Transmission rate up
          icon: 'mdi:cloud-upload'
        - type: entity
          entity: sensor.fritzbox_netzwerk_monitor
          attribute: bytes_received
          unit: Bytes
          name: Bytes empfangen
          icon: 'mdi:download'
        - type: entity
          entity: sensor.fritzbox_netzwerk_monitor
          icon: 'mdi:upload'
          name: Bytes gesendet
          unit: Bytes
          attribute: bytes_sent

      Jetzt zu meinem Problem. Ich würde gerne die Daten von Bytes in Gigabyte umrechnen und habe einiges probiert, jedoch bleibt der Wert in Bytes.

      Im Entwicklerwerkzeug -> Vorlage wird mir mit dem Code, welcher auch in der configuration.yaml eingetragen ist korrekt angezeigt:

      Entwicklerwerkzeug

      Dazu der Code:

      <code class="language-markup-templating">  - platform: template  
          sensors:
            bytes_sent:
              friendly_name: Bytes gesendet
              unit_of_measurement: GB
              value_template: "{{ (state_attr('sensor.fritzbox_netzwerk_monitor', 'bytes_sent' ) | float / 1024 / 1024 / 1024) | round(2) }}"

      Hat jemand eine Idee woran das liegen könnte, dass mir in der Kachel weiterhin der Wert Bytes angezeigt wird?

      Danke & Gruß

      butzibutz

      P.S. Bitte habt ein wenig Rücksicht falls ich einen Anfängerfehler begangen haben sollte. Ich bin wirklich blutiger Anfänger mit Home Assistant 🙂

    • #1710
      m4d-maNu
      Teilnehmer

      Deine Umrechnung schaut falsch aus:

       

      Du hast

      value_template: "{{ (state_attr('sensor.fritzbox_netzwerk_monitor','bytes_sent') | float / 1024 / 1024 / 1024) | round(2) }}"
      
      
      

      Versuch es mal mit dieser Zeile hier

      value_template: "{{ states('sensor.transmission_up_speed','bytes_sent')|float / 1073741824 }}"

       

      • Diese Antwort wurde geändert vor 3 Monaten, 2 Wochen von m4d-maNu.
      • Diese Antwort wurde geändert vor 3 Monaten, 2 Wochen von m4d-maNu.
      • Diese Antwort wurde geändert vor 3 Monaten, 2 Wochen von m4d-maNu.
      • #1715
        butzibutz
        Teilnehmer

        Hallo,

        vielen Dank für deine Antwort.

        Mit deinem angegeben Code erhalte ich folgenden Fehler:

        TypeError: __call__() takes 2 positional arguments but 3 were given
        
        Nutze ich einen Teil von deinem Code und ändere meinen Code ab, dann erhalte ich wie mit meinem alten Code ein Ergebnis.
        
        <code class="language-markup-templating">value_template: "{{ (state_attr('sensor.fritzbox_netzwerk_monitor','bytes_sent')) | float / 1073741824 }}"
        Ergebnis mit dem umgebauten Code:
        
        value_template: "8.645091522485018"
        Ergebnis mit dem alten Code:
        
        value_template: "8.65"
        Des Weiteren habe ich folgenden Code versucht:
        
        <code class="language-markup-templating">value_template: "{{ (state_attr('sensor.transmission_up_speed','bytes_sent')) | float / 1073741824 }}"
                
        Das Ergebnis ist dann folgendes:
        
        value_template: "0.0"
        
        Ich habe den umgebauten Code in die configuration.yaml eingebaut und Home Assistant neu gestartet, jedoch wird weiterhin das Ergebnis in Bytes angezeigt.
        
        Gruß
        butzibutz 
        
        
    • #1714
      m4d-maNu
      Teilnehmer

      Hab oben den falschen Befehl drinnen gehabt, den hast du aber ja passend abgeändert. Ist mir zu spät aufgefallen, da konnte ich schon nicht mehr bearbeiten.

       

      Und jetzt checke ich das Problem erst, es war nicht das Problem dass nicht Umgerechnet wurde sondern das die Einheit falsch angezeigt wird.

      • Diese Antwort wurde geändert vor 3 Monaten, 2 Wochen von m4d-maNu.
      • Diese Antwort wurde geändert vor 3 Monaten, 2 Wochen von m4d-maNu.
      • #1718
        m4d-maNu
        Teilnehmer

        Was passiert wenn du direkt den Code der Kachel änderst: Da trägst du ja als united Byte ein, probier doch direkt da das ändert auf GB.

      • #1719
        butzibutz
        Teilnehmer

        Hallo,

        Problem richtig verstanden.

        Die Umrechnung funktioniert nur wird es in der Kachel falsch angezeigt.

        Vieleicht habe ich doch irgendwo einen Anfängerfehler begangen?

        Aber mehr als in der configuration.yaml eintragen und den Server neustarten, kann ich doch gar nicht tun, oder?

        Gruß

        butzibutz

    • #1720
      butzibutz
      Teilnehmer

      Was passiert wenn du direkt den Code der Kachel änderst: Da trägst du ja als united Byte ein, probier doch direkt da das ändert auf GB.

      Das bringt keine Änderung bei den Werten nur das statt Bytes jetzt GB hinter dem Wert steht.

    • #1723
      m4d-maNu
      Teilnehmer

      Ich würde gern versuchen dir zu helfen, aber ich scheitere schon an der Installation von dieser Integration. Nehme ich den Part von dir (angepasst auf meine IP der FritzBox) so kommt einfach nur eine Fehlermeldung, dass die Configuration fehlerhaft ist. Nutze ich die Version wie es auf der Webseite angeben ist, kommt zwar keine Fehlermeldung aber es wird auch kein Sensor etc. erzeugt.

      • #1724
        butzibutz
        Teilnehmer

        Guten Morgen,

        jetzt bin ich aber ein bisschen verwundert, weil den Code habe ich von einem Bekannten erhalten und habe in nur auf meine IP angepasst. Nachdem Eintrag in der configuration.yaml habe ich Home Assistant neugestartet und dann war der Sensor verfügbar.

        Hast du diesen Punkt durchgeführt:

        For this integration to function properly, you need to have “UPnP Statusinformation transfer” activated on the AVM FRITZ!Box. Please make sure you have that enabled.

        Ich habe in der FritzBox nichts angepasst, weil mein Bekannter (IT-Administrator) sagte das dieses normalerweise standardmäßig eingeschaltet ist.

        Gruß

        butzibutz

    • #1725
      m4d-maNu
      Teilnehmer

      Ah, diesen Punkt habe ich glatt überlesen bzw. vergessen dass ich erst letzte Woche UPnP abgeschaltet habe bei mir. Denn dadurch habe ich einfach Millionen (gefühlt und bisschen übertrieben) Geräte in der Netzwerk Umgebung bei Windows 10 (denn das habe ich unteranderem auch im Einsatz) und leider kann ich auf den Geräten das selbst nicht immer abschalten und daher habe ich es auf der FritzBox direkt abgeschaltet, denn dass ist wirklich Standardmässig aktiv.

      Wobei es mich dann immer noch seltsam ist, dass HA sagt ich habe einen Fehler in der Config… Die Config wäre ja dann eigentlich richtig, nur kann der Status nicht ausgelesen werden.

       

       

      # FritzBox Netmonitor
        - platform: fritzbox_netmonitor
          name: FritzBox Netzwerk Monitor
          host: 192.168.1.1

      Das kommt, wenn ich deine Config angepasst übernehme (auch wenn UPnP an ist).

      Error loading /config/configuration.yaml: while parsing a block mapping in 
      "/config/configuration.yaml", line 26, column 3 expected <block end>, 
      but found '-' in "/config/configuration.yaml", line 30, column 3

       

      Wenn ich die Config Installation von der Webseite nehme

      sensor:
      – platform: fritzbox_netmonitor

      So funktioniert es, der Sensor wird erzeugt und nun kann ich mich damit rumspielen dass die Kachel keinen xxxxxxxxxxxxxxxxxxxx Bytes mehr anzeigt sondern xx GB. Bei den ersten Versuchen ist mir auch aufgefallen, es geht ohne Probleme das xxxxxxxxxxxxxxxxxxxx GB angezeigt werden. Was schon mal ja die halbe Niete ist, denn die Einheit ist geändert aber der Wert selber sind immer noch Bytes und nicht der von GB. Die Umrechnung selbst, kann in der Kachel auch nicht gemacht werden, entsprechend muss ich nun schauen wo ich diese Umrechnung machen kann.

      • Diese Antwort wurde geändert vor 3 Monaten, 2 Wochen von m4d-maNu.
      • #1727
        butzibutz
        Teilnehmer

        Klasse das du die Integration hinbekommen hast. Ich habe gestern auch den Wert in GB geändert, jedoch war das für die reine Anzeige und der Wert war weiterhin in Bytes.

        Ich hatte die Umrechnung auch in der Konfiguration der Kachel und habe es dann in die configuration.yaml verschoben, weil ich das auf verschiedenen Webseiten gelesen habe.

        Was ich nicht verstehe, dass im Entwicklerwerkzeuge-> Vorlage die Umrechnung funktioniert und sobald es in die configuration.yaml übertragen wird nicht mehr.

        Gruß

    • #1728
      m4d-maNu
      Teilnehmer

      Also ich selbst komme da aktuell auch nicht wirklich weiter, denn es müsste ja eine Customize Entitäten erstellt werden und genau hier scheitere ich gerade. Wenn ich eine customize.yaml erzeuge und darin dann den die eigene Entität erstelle und in die Config noch dazu schreibe customize: !include customize.yaml (genau da wo auch die anderen yaml aufgelistet werden), so heißt es er kann Customize nicht finden.

       

    • #1729
      butzibutz
      Teilnehmer

      Vielen Dank für deine Unterstützung. Vielleicht hat noch ein anderer Nutzer in diesem Forum eine Idee. Ich werde mir das am Wochenende nochmals in Ruhe ansehen.

       

    • #1732
      Osorkon
      Teilnehmer

      Mal eine blöde Frage.

      Verweist  Du in Deiner Kachel immer noch auf das Attribut „bytes_sent“ des Sensors „sensor.fritzbox_netzwerk_monitor“?

      Oder hast Du diesen bereits durch den neu von Dir erstellten Sensor „sensor.bytes_sent“ ersetzt?

      • #1733
        butzibutz
        Teilnehmer

        Hallo,

        du bist mein Held 🙂

        screenshot-1

        Genau das war mein Fehler. Wie oben geschrieben habe ich doch einen Anfängerfehler begangen.

        Vielen Dank für die tolle Unterstützung. Bin wirklich froh das ich dieses Forum gefunden habe.

        Man lernt jeden Tag dazu.

        Gruß

        butzibutz

    • #1739
      Osorkon
      Teilnehmer

      @butzibutz Gerne ☺️

      Kannst mal auch in den Slack Channel vorbeischauen, da kann Dir auch geholfen werden. Gilt natürlich für alle anderen Interessierten auch. 😀

      Gruß Osorkon

    • #1878
      akia
      Teilnehmer

      Hallo,

      ich verwende diese Darstellung auch, nur fällt mir auf das bei > 4,1 GB der Zähler wieder auf 0 geht. Warum ist das so? Hätte gerne die gesendete/empfange Datenmenge in einem Zeitraum (zB. Monat).

    • #2530
      wuschel
      Teilnehmer

      Hallo und guten Abend,

      habe mir heute exakt die Darstellung wie im 1 Post angelegt. Läuft auch soweit sauber, an welcher Stellschraube muss ich jetzt drehen damit es sauber dargestellt wird ?

      Den Codeschnipsel am Ende des ersten Posts habe ich ebenfalls mal in die Entwicklertools gesteckt und es wurden 0.41 dargestellt, was ich für realistisch erachte.

      Gruß

      • #2566
        wuschel
        Teilnehmer

        Habe es mitlerweile gelöst und es wird in GB angezeigt 🙂

    • #2575
      xenix
      Teilnehmer

      Hallo zusammen,

       

      also den netmonitor in der config habe ich.

      Aber bei der Kachel scheitert es.

      bekomme immer das keine entitäten verfügbar sind.

      Könnte freundlicherweise jemand mir das nochmal erklären wie ich diese Kachel einrichte ?

       

Ansicht von 12 Antwort-Themen
  • Du musst angemeldet sein, um auf dieses Thema antworten zu können.