CALDAV Synology

Forum Forum Schnelle Frage CALDAV Synology

Ansicht von 9 Antwort-Themen
  • Autor
    Beiträge
    • #1215
      DIeter001
      Teilnehmer

      Moin,
      frage, weiß jemand wie ich einen CalDAV Kalender anzeige?
      Zugangsdaten in der Config eingetragen, aber dann?

      Danke im voraus

    • #1248
      David
      Verwalter

      Tauchen seine Daten denn in den Zuständen auf?

       

      Im Hacs gibt es diverse Lovelace Karten für die Darstellung von Terminen

       

       

    • #1251
      DIeter001
      Teilnehmer

      Wie heißt das Teil? Es wird mir zwar ein Kalender angezeigt, jedoch keine eingetragenen Inhalte …

    • #2228
      thobo
      Teilnehmer

      Moin,

      um keinen neuen Thread zu eröffnen: Ich habe dasselbe Problem.

       

      Home Assistent läuft auf einer Syno als Docker. Kalender auf dem Iphone und unter Thunderbird einwandfrei zu erreichen.

      Auf dem Home Assistant beim ersten Mal einrichten hatte es super geklappt, Danach wurden mir (irgendwann) keine Kalenderdaten mehr angezeigt.
      Habe dann in Ermangelung besserer Ideen mit den Zertifikaten gespielt (und durfte dann bei IOS und TB die Kalender neu einrichten).

      Eingerichtet ist der Kalender nach Standard: https://www.home-assistant.io/integrations/caldav/

      Fehlermeldung beim Serverneustart bekomme ich keine,
      Die Kalender werden mir auch nicht als Entität angezeigt.

      Was tun?

      Schon mal vielen Dank fürs lesen 🙂

      Edit: Einrichtungshinweis hinzugefügt

      • Diese Antwort wurde geändert vor 2 Monaten, 4 Wochen von thobo.
      • Diese Antwort wurde geändert vor 2 Monaten, 4 Wochen von thobo.
      • #2235
        DIeter001
        Teilnehmer

        Hi thobo,
        also, ich hab es hin bekommen, allerdings nur über eine Domain, nicht über die IP der Synology.
        Aus Sicherheitsgründen hab ich in der Synology einen Benutzer angelegt, die nur auf den Kalender Zugriff hat.
        Diesem hab ich auch den Zugriff auf FileStation entzogen. Dem entsprechenden Kalender der Synology muß noch der neue Benutzer

        frei gegeben werden unter Calendar: Kalender (Kalender auswählen Pfeil runter) Freigeben.
        unter Mit DSM-Benutzer teilen den neuen Benutzer auswählen.
        calendar:
        – platform: caldav
        username: <Neuer Benutzer für Calender Synology>
        password: <Passwort Neuer Benutzer für Calender Synology>
        url: https://<domain synology>:<port synology>/caldav.php/<Nutzer aus CalDAV-Konto>

        Wenn ich folgendes in der Configuration.yaml angebe, geht es nicht !!!
            custom_calendars:
              – name: ‚mein Kalender‘
                calendar: ‚Agenda‘
                search: ‚kalender‘

        Das der Kalender nicht über die IP erreichbar ist, scheint tatsächlich daran zu liegen, das für eine IP als https kein Zertifikat vorliegt.

        ABER … ich hab jetzt auch das hin bekommen.
        Und zwar
        calendar:
        – platform: caldav
        username: <Neuer Benutzer für Calender Synology>
        password: <Passwort Neuer Benutzer für Calender Synology>
        url: http://<IP synology>:<port synology ohne https>/caldav.php/<Nutzer aus CalDAV-Konto>
        DSM 6.2.3:
        Der Port ist in der Synology unter Systemsteuerung / Netzwerk / DSM-Einstellungen (DSM Ports) zu finden.
        Standard wäre 5000
    • #2231
      DIeter001
      Teilnehmer

      hab es auch noch nicht hin bekommen, das sensoren für einen Synology Kalender generiert werden.
      Hab heute die Beschreibung von der Seite versucht: https://gh2home.nl/integrations/integrate-synology-calendar-using-caldav/
      Leider auch kein Erfolg 🙁

    • #2236
      thobo
      Teilnehmer

      Hallo Dieter,

      schonmal vielen Dank für deine ausführliche Antwort.

      bei mir hatte es ja bei der Ersteinrichtung super geklappt, ein paar Tage später kam auf dem Kalender nichts mehr an.

      Adresse  lautete bei mir von Beginn an:

      https://Domainname:Port/caldav.php/Benutzername

      Die Konfiguration  ist ansonsten genauso:

      Der Kalenderbenutzer hat einen eigenen Zugang, und auch nur Zugriff  auf den Kalender und auf nix anderes.

      Den Spaß mit:

      —-Snip—-

      custom_calendars:
            – name: ‚mein Kalender‘
              calendar: ‚Agenda‘
              search: ‚kalender‘
      —-end snip—-
      hatte ich gar nicht erst versucht.

      Auf die Idee mit dem ungesicherten Port kam ich auch schon, hatte aber zumindest übers I-Net auch keinen Erfolg.

      Ich werde es aber nochmal probieren  Theoretisch sollte es ja zumindest über den ungesicherten Port im internen NW funktionieren. Wird aber erst zum Ende der Woche….

      Viele Grüsse

      thobo

      • #2240
        DIeter001
        Teilnehmer

        Also bei mir ist es jetzt seit zweit Tagen am laufen und geht. Auf einem Raspberry Pi sowie auf einer Synology (zum Testen) in einer Virtuellen Maschine. Es auf Docker zu installieren hab ich nicht mehr hin bekommen, soll auch nicht merh unterstützt werden? Keine Ahnung.
        Schau doch mal deine Portfreigaben an, mal testen ob es geht, wenn du die Firewall der Syno abschaltest. Was http(s) betrifft, so hab ich auch das nun hin bekommen. Da ich eine Domain habe die über Dyndns auf meine homeIP zeigt, geht das Zertifikat auch auf meinem Pi über Reverse Proxy. Nachteil an dem Reverse Proxy ist nur, das es nur funktioniert, wenn Raspberry & Syno an sind 🙁

         

    • #2262
      thobo
      Teilnehmer

      Moin,

      kleines Feedback:
      Ich hatte es eingerichtet (interne IP) alles bestens. Kalender ( ingesamt 4) waren da,
      tlw. mussten die Widgets neu eingerichtet werden -> alles hübsch.
      (Die Ladezeiten / Aktualisierungsrate ist irgendwie auch sehr lange)

      Nach einem Serverneustart fehlt auf einmal ein! Kalender.
      Nichts geändert.
      Syno gerade nochmal neu gestartet, der Kalender fehlt immer noch.
      Begebe mich mal auf Fehlersuche.

      Gruss
      ThoBo

      • #2265
        DIeter001
        Teilnehmer

        Hi,
        hab HomeAssistant auf nem Pi laufen und parrallel zu Testen in einer Virtuellen Maschine auf der Synology.
        Habe bis heute kein Problem mit den Kalendern gehabt. Heute morgen waren sie weg. Muß aber gestehen, ich hab gestern viel probiert mit Nginx Proxy Manager als Reverse Proxy. Hab auch in meiner Fritte an den Portfreigaben & Weiterleitungen getestet.
        Hab nun in der Fritte die Port Freigaben geprüft und den Pi komplett neu gestartet. Alles wieder da!
        Mal die Firewall geprüft / abgeschalten?
        Prüf auch die Portfreigaben im Router

         

    • #2273
      thobo
      Teilnehmer

      Moin,

      die Probleme im internen Netz sind (eigentlich) gelöst:

      Egal wie ich die Kalender in der Syno konfiguriert ex~und importiert hatte – ein Kalender (immer derselbe) wurde nicht im HA angezeigt.
      Habe daraufhin einen zusätzlichen leeren Kalender erstellt und angefangen nach dem Import die Termine händisch von einem in den anderen Kalender zu verschieben.

      Das Problem der nicht angezeigten Termine liegt an in der Zukunft liegenden Terminen mit einer Dauer von 0 Minuten.
      In der Vergangenheit liegende Termine mit Nulldauer sind wohl egal.

      Liegt aber ein Termin in der Zukunft, mit Dauer 0 werden im Kalender und im Widget <span style=“text-decoration: underline;“>gar keine</span> Termine mehr angezeigt. Das hat mich natürlich arg irritiert!
      Ich vermute mal einen BUG.
      Ein weiterer BUG ist das ganztägige ggf. mehrtägige Termine mit Startzeit 0:00 und nur am ersten Tag angezeigt werden!

      Warum mir der o.g. Kalender nach dem Import gar nicht angezeigt wird habe ich jetzt noch nicht nachvollziehen können. Ich vermute das hier zusätzliche Parameter im Termin (evtl . SMS Versand) schuld sind. Vielleicht schaue ich mir das nächste Woche noch mal an.

      Zugriff über https fkt. weder von innen noch von ausserhalb des NW.
      https Zugriff innerhalb des Netzwerks ebenfalls (noch) nicht möglich!
      Zugroff von aussen über den ungesicherten Port ebenfalls noch nicht möglich.

      Ostern geht es evtl weiter.



      @Dieter

      Vielen Dank für deine Tipps

       

      mfg
      ThoBo

      • #2286
        DIeter001
        Teilnehmer

        Moin ThoBo,
        hab nochwas festgestellt 🙂
        Und zwar, nutze ich ja einen RaspBerryPi für HomeAssistant. Startet dieser neu, und die Synology ist AUS, werden die Calendar-Sensoren nicht erstellt. Schau mal bei Dir, wenn der Kalender weg ist, ob die Sensoren da sind.
        Da könnte das Übel liegen wenn sie manchmal da, manchmal weg sind
        Grüße

    • #2279
      DIeter001
      Teilnehmer

      Moin ThoBo,
      also, ich hab jetzt mal geschaut. Du scheinst recht zu haben,
      – Termin, mit Dauer null verursacht, das keinerlei Termine mehr angezeigt werden !!!
      – bei Terminen die um 0:00 beginnen und mehrere Tage dauern, wird nur der erste Tag angezeigt !!!
      Beide Dinge sind auch bei mir reproduzierbar!! Deine Vermutung von Bugs hierzu wird wohl stimmen.

      Hab auch getestet, was passiert, wenn man so einen Termin im Apple Kalender ausgibt. Geht, wenn er sich
      Auch massiv sträubt, einen Termin mit 0 Minuten zu akzeptieren (macht ja auch nicht wirklich Sinn 🙂

      Hab nun für Syno Calendar http und https versucht. Geht beides. Voraussetzung für https ist aber ein Zertifikat
      und eine zugängliche Domain mit passender Portfreigabe im Router.

      Bsp HTTP:

      calendar:
      – platform: caldav
      username: Synology-Benutzer
      password: Synology-Passwort
      url: http:// <ip-synology> : 5000/caldav.php/<user aus CalDav-Konto im Calenar Syno>

      Port 5000 (Verwaltungsprogramm Port intern) muß in der Syno-Firewall eingetragen sein (hab den auf meine Internen IP´s begrenzt)
      Die in der Sync-Firewall angegebenen Ports für Calendar (38008 / 38443) sind bei mir irrelevant (why ever die da angegeben werden können)

      Bsp HTTPS: (hab ich nur zu Testzwecken genutzt. Intern reicht mir ja, weil Extern über HA)

      calendar:
      – platform: caldav
      username: Synology-Benutzer
      password: Synology-Passwort
      url: http:// <ip-synology> : <Port über den Deine Sync aus dem Web erreichbar ist>/caldav.php/<user aus CalDav-Konto im Calenar Syno>

      Der Port über den Deine Sync aus dem WEB erreichbar ist muß in der Syno-Firewall eingetragen sein (hab den auf meine Internen IP´s begrenzt)
      Ich hab hier eine Portfreigabe im Router für den entsprechend Port für die Syno (frei wählbar)
      Es handelt sich hier nicht um einen in der Syno angegebenen Port unter Externer Zugriff, sondern um die Ports unter Systemsteuerung / Netzwerk / DSM-Einstellungen

      DSM-Ports:

      – HTTP: 5000 (kann man auch nen anderen nehme wenn es mal geht 🙂 , ist mir aber Wurscht, weil ja auf Interne IP´s begrenzt)
      – HTTPS: 12345
      – (X) HTTP-Verbindung automatisch auf HTTPS
      – (X) HTTP/S aktivieren
      – (X) „Server“-Header in HTTP-Antworten aktivieren

      Bsp: So ist dann die Syno aus dem Web erreichbar.
      https:// <deineDomain> : 12345

      Der Bsp-Port 12345 muß in der Syno Firewall eingetragen sein! Aber nicht auf Land begrenzen, das geht nicht, why ever. Wenn ich auf DE Begrenze würde ich mich laut Firewall aussperren
      Bin aber sicher in DE 🙂

      So funktioniert es bei mir Prima

      Für die Erreichbarkeit aus dem Web ist verschiedenes möglich.
      – DynDNS von Anbieter XYZ (Hab mit Selfhost super Erfahrungen , Domain mit DynDNS 12 Euro im Jahr)
      – MyFritz (wenn man ne Fritte hat (Wenigstens ein deutscher Anbieter für kostenlose DynDNS)
      – QuickConnect von Synology Da werden die Server wohl in Asien laufen

      Zertifikate und Möglichkeiten in Syno / HomeAssistant
      Synology Zertifikat für Deine Domain über Sicherheit / Zertifikat / Hinzufügen / neues Zertifikat / Zertifikat von Letscrypt abrufen
      Die lässt sich dann über eine ReverseProxy Einstellung nutzen (Systemsteuerung / Anwendungsportal/ReverseProxy/Erstellen)
      Oder in HomeAssistant unter Supervisor / AddOn-Shop MariaDB intsallieren und einrichten +
      Nginx Prox Manager installieren und einrichten (geht auch prima)

      • Diese Antwort wurde geändert vor 2 Monaten, 2 Wochen von DIeter001.
    • #2290
      thobo
      Teilnehmer

      Moin,

      ich möchte das Thema CalDav -Anzeige der Kalender(inhalte) im HA  an dieser Stelle für mich abschliessen.

      Es funktioniert jetzt einwandfrei:
      Alle Kalender werden angezeigt. Das dies anfangs nicht so war liegt an einem BUG, der der verhindert das überhaupt ein (sprich alle) Kalender angezeigt wird, wenn in der Zukunft Termine eingetragen sind die keine Dauer haben (Anfangs = Endzeit)

      HA ist in Docker auf einer Syno installiert.Der Zugriff auf den Kalender (configuration.yaml) läuft innerhalb meines Netzwerkes über den ungesicherten Port (über den gesicherten kein Kalenderzugriff). Ich habe daher einen separaten Benutzer angelegt, der nur  Zugriff auf die freigegebenen Kalender hat.

      Das nächste Thema wird dann eine Automation sein die ausgeführt wird wenn im Kalender das Stichwort „Urlaub“ enthält.

      Viele Grüsse vielen Dank für eure Ratschläge.

      Allen noch ein schönes Osterfest

      Gruss
      ThoBo

Ansicht von 9 Antwort-Themen
  • Du musst angemeldet sein, um auf dieses Thema antworten zu können.