HA Core Update über command line zeigt kein Wirkung

Forum Forum Schnelle Frage HA Core Update über command line zeigt kein Wirkung

Schlagwörter: , ,

Ansicht von 0 Antwort-Themen
  • Autor
    Beiträge
    • #1657
      OrTiN
      Teilnehmer

      Hallo zusammen,

      ich versuche meine Core (Proxmox Ubuntu VM) installation, die ich kurz vor Weihnachten aufgesetzt habe zu aktualisieren. Laut Anleitung sind es drei simple Befehle, aber nach Serverneustart zeigt sich HA unbeeindruckt und zeigt weiterhin die Version vor dem vermeintlichen Update an:

      <code class="language-markup-templating">version: 2020.12.1
      installation_type: Home Assistant Core
      dev: false
      hassio: false
      docker: false
      virtualenv: true
      python_version: 3.8.0
      os_name: Linux
      os_version: 4.15.0-129-generic
      arch: x86_64
      timezone: Europe/Berlin<br><br>

      Ich nutze bis lang folgende Befehle aus dieser Anleitung: https://www.home-assistant.io/docs/installation/virtualenv

      <code class="language-markup-templating">cd homeassistant
      source bin/activate
      python3 -m pip install --upgrade homeassistant

      Zurück bekomme ich folgendes, so dass man glauben könnte, dass das Update erfolgreich war. Beim ersten mal habe ich gesehen, dass etwas installiert wurde, inzwischen kommt nur noch folgendes:

      <code class="language-markup-templating">Requirement already satisfied: homeassistant in ./lib/python3.6/site-packages (0.103.6)
      Requirement already satisfied: pyyaml==5.1.2 in ./lib/python3.6/site-packages (from homeassistant) (5.1.2)
      Requirement already satisfied: ruamel.yaml==0.15.100 in ./lib/python3.6/site-packages (from homeassistant) (0.15.100)
      Requirement already satisfied: pytz>=2019.03 in ./lib/python3.6/site-packages (from homeassistant) (2020.5)
      Requirement already satisfied: attrs==19.3.0 in ./lib/python3.6/site-packages (from homeassistant) (19.3.0)
      Requirement already satisfied: importlib-metadata==0.23 in ./lib/python3.6/site-packages (from homeassistant) (0.23)
      Requirement already satisfied: astral==1.10.1 in ./lib/python3.6/site-packages (from homeassistant) (1.10.1)
      Requirement already satisfied: async-timeout==3.0.1 in ./lib/python3.6/site-packages (from homeassistant) (3.0.1)
      Requirement already satisfied: python-slugify==4.0.0 in ./lib/python3.6/site-packages (from homeassistant) (4.0.0)
      Requirement already satisfied: bcrypt==3.1.7 in ./lib/python3.6/site-packages (from homeassistant) (3.1.7)
      Requirement already satisfied: certifi>=2019.9.11 in ./lib/python3.6/site-packages (from homeassistant) (2020.12.5)
      Requirement already satisfied: PyJWT==1.7.1 in ./lib/python3.6/site-packages (from homeassistant) (1.7.1)
      Requirement already satisfied: cryptography==2.8 in ./lib/python3.6/site-packages (from homeassistant) (2.8)
      Requirement already satisfied: aiohttp==3.6.1 in ./lib/python3.6/site-packages (from homeassistant) (3.6.1)
      Requirement already satisfied: requests==2.22.0 in ./lib/python3.6/site-packages (from homeassistant) (2.22.0)
      Requirement already satisfied: voluptuous==0.11.7 in ./lib/python3.6/site-packages (from homeassistant) (0.11.7)
      Requirement already satisfied: voluptuous-serialize==2.3.0 in ./lib/python3.6/site-packages (from homeassistant) (2.3.0)
      Requirement already satisfied: contextvars==2.4 in ./lib/python3.6/site-packages (from homeassistant) (2.4)
      Requirement already satisfied: pip>=8.0.3 in ./lib/python3.6/site-packages (from homeassistant) (20.3.3)
      Requirement already satisfied: jinja2>=2.10.3 in ./lib/python3.6/site-packages (from homeassistant) (2.11.2)
      Requirement already satisfied: idna-ssl>=1.0 in ./lib/python3.6/site-packages (from aiohttp==3.6.1->homeassistant) (1.1.0)
      Requirement already satisfied: chardet<4.0,>=2.0 in ./lib/python3.6/site-packages (from aiohttp==3.6.1->homeassistant) (3.0.4)
      Requirement already satisfied: multidict<5.0,>=4.5 in ./lib/python3.6/site-packages (from aiohttp==3.6.1->homeassistant) (4.7.6)
      Requirement already satisfied: typing-extensions>=3.6.5 in ./lib/python3.6/site-packages (from aiohttp==3.6.1->homeassistant) (3.7.4.3)
      Requirement already satisfied: yarl<2.0,>=1.0 in ./lib/python3.6/site-packages (from aiohttp==3.6.1->homeassistant) (1.6.3)
      Requirement already satisfied: cffi>=1.1 in ./lib/python3.6/site-packages (from bcrypt==3.1.7->homeassistant) (1.14.4)
      Requirement already satisfied: six>=1.4.1 in ./lib/python3.6/site-packages (from bcrypt==3.1.7->homeassistant) (1.15.0)
      Requirement already satisfied: immutables>=0.9 in ./lib/python3.6/site-packages (from contextvars==2.4->homeassistant) (0.14)
      Requirement already satisfied: zipp>=0.5 in ./lib/python3.6/site-packages (from importlib-metadata==0.23->homeassistant) (3.4.0)
      Requirement already satisfied: text-unidecode>=1.3 in ./lib/python3.6/site-packages (from python-slugify==4.0.0->homeassistant) (1.3)
      Requirement already satisfied: urllib3!=1.25.0,!=1.25.1,<1.26,>=1.21.1 in ./lib/python3.6/site-packages (from requests==2.22.0->homeassistant) (1.25.11)
      Requirement already satisfied: idna<2.9,>=2.5 in ./lib/python3.6/site-packages (from requests==2.22.0->homeassistant) (2.8)
      Requirement already satisfied: pycparser in ./lib/python3.6/site-packages (from cffi>=1.1->bcrypt==3.1.7->homeassistant) (2.20)
      Requirement already satisfied: MarkupSafe>=0.23 in ./lib/python3.6/site-packages (from jinja2>=2.10.3->homeassistant) (1.1.1)

      Da ich sehr neu in HA bin, übersehe ich sicherlich etwas, komme aber nicht selber drauf was es ist. Könnt ihr mir vllt. Hilfestellung geben?

      Gruß,
      OrTiN

Ansicht von 0 Antwort-Themen
  • Du musst angemeldet sein, um auf dieses Thema antworten zu können.