Problem mit Python bei der Installation auf Raspberry 4

Forum Forum Schnelle Frage Problem mit Python bei der Installation auf Raspberry 4

Ansicht von 6 Antwort-Themen
  • Autor
    Beiträge
    • #1984
      stefang
      Teilnehmer

      Hallo,

      ich habe diese Anleitung befolgt:https://www.home-assistant.io/docs/installation/raspberry-pi/

      ich habe 2 Python Versionen drauf (und keine Ahnung wie ich eine los werde)
      $ python –version
      Python 3.7.3
      $ python3 –version
      Python 3.9.0

      An dem Installationpunkt „python3.8 -m venv .“ komme ich nicht weiter:
      python3 -m venv .
      bash: python3: Kommando nicht gefunden.

      $ python3.9 -m venv .
      bash: python3.9: Kommando nicht gefunden.

      $ python3.9.0 -m venv .
      bash: python3.9.0: Kommando nicht gefunden.

      Am Ende kommt dann das da:
      pi@raspberrypi:/home/homeassistant $ hass
      Unable to find configuration. Creating default one in /home/pi/.homeassistant
      2021-02-11 17:18:58 WARNING (MainThread) [homeassistant.bootstrap]
      Support for the running Python version 3.7.3 is deprecated and will be removed in the first release after December 7, 2020. Please upgrade Python to 3.8.0 or higher.

      Ihr merkt ich bin kein Untis-Nutzer, kann mir bitte jemand ein Tipp geben?

      Gruß Stefan

    • #1985
      Osorkon
      Teilnehmer

      Hallo Stefan und Willkommen.

       

      Mal eine blöde Frage. Warum nicht einfach Home Assistant OS?

      Einfacher und unkomplizierter kann man es nicht haben, gerade als Einsteiger.

      Und Du schreibst ja selber, dass Linux und Du nicht gerade Freunde sind!

      Gruß Osorkon

    • #1986
      stefang
      Teilnehmer

      Ist keine blöde Frage

      nachdem ich halt wochenlang an meinem Raspberry gearbeitet habe und endlich mal alle Anwendungen laufen,

      will ich ja nicht nochmal von vorne anfangen.

    • #1987
      Osorkon
      Teilnehmer

      Welche Anwendungen hast Du auf dem Pi laufen, für die es kein  Add-on in HA OS gibt?

      Will Dich natürlich nicht davon abhalten, alles manuell zu installieren.

      Ich persönlich hätte mich wahrscheinlich nicht auf HA eingelassen, wenn es HA OS nicht gäbe.

    • #1989
      stefang
      Teilnehmer

      naja z.B. meine selbstgebaute und programmierte EMA

      Ich habe jetzt das fertige Image mal auf einem zweiten Raspberry ausprobiert.  Einfach einstecken und läuft!

      Ist ja ganz nett aber ich bin damit nicht so richtig glücklich, weil ich es nicht selber geschafft habe.
      Ich werde noch ein paar Sachen ausprobieren.

      Mache mir gerade eine neue Karte fertig mit dem Original-BS
      (https://www.raspberrypi.org/software/raspberry-pi-desktop/).
      Irgendwie muss man doch Python auf die aktuelle Version bringen können. Das Problem stellt sich doch irgendwann

    • #1995
      pihlo
      Teilnehmer

      Hoi Stefan, ich habe genau das selbe gehabt. Die Fehlermeldung kommt weil du eben kein PY3.8 hast (ist im Original Rasbian Image nicht drin). Lösung die funktioniert – gestern probiert – ist Python nach zu installieren gemäss dieser deutschen Maker Anleitung.

      Wenn Du da durch bist (auf meinem RB4 ca 1h) dann kannst Du mit der Anleitung die Du verlinkst weitermachen – es funktioniert….

       

    • #1999
      stefang
      Teilnehmer

      Danke, ich habe es jetzt nach dieser Anleitung geschafft.
      https://community.home-assistant.io/t/python-3-9-install-on-raspberry-pi-os/241558
      Habe jetzt Python 3.9.1 und ein funktionierendes Raspbery Pi OS.

Ansicht von 6 Antwort-Themen
  • Du musst angemeldet sein, um auf dieses Thema antworten zu können.