Sonnenaufgang anzeigen in Kachel als Uhrzeit

Forum Forum Schnelle Frage Sonnenaufgang anzeigen in Kachel als Uhrzeit

Ansicht von 7 Antwort-Themen
  • Autor
    Beiträge
    • #2601
      maxnomo
      Teilnehmer

      Hallo,

      habe in sun.sun die Daten für den Sonnenaufgang extrahiert und bekomme die jetzt angezeigt.

      Aber in einem ewig langen Format incl Datum wie folgt:  „2021-05-01T18:44:14+00:00“

      Wie extrahiere davon nur die Uhrzeit zur Anzeige.

       

      Wahrscheinlich easy aber bin erst seit kurzem dabei.

      Danke

      • Dieses Thema wurde geändert vor 4 Tage, 23 Stunden von maxnomo.
    • #2604
      David
      Verwalter
      Folgendes in deine config, dann solltest du es als neue Entität  haben
      
      sensor: 
        - platform: template
          sensors:
            nextsunrise:
              entity_id: sun.sun
              friendly_name: 'Sonnenaufgang'
              value_template: >
                {{ as_timestamp(states.sun.sun.attributes.next_rising) | timestamp_custom(' %H:%M')  }}
              icon_template: mdi:weather-sunset-up
      
      
      

       

      • Diese Antwort wurde geändert vor 4 Tage, 21 Stunden von David.
      • #2606
        maxnomo
        Teilnehmer

        Hallo @David: hat im Prinzip geklappt.  Kommt aber immer mit nem Hochkomma davor:  ‚ 18:45 Uhr

        Wäre schön, wenn das weg wäre. Ausserdem ist das UTC Zeit , daher müsste ich für meinen Standort 2 Stunden draufrechnen, oder kann man die Zeitzone irgendwo einstellen ?

        Aber schonmal danke..

         

        PS: das Hochkomma wird hier oben als Komma dargestellt: HOCHKOMMA18:45 Uhr

        • Diese Antwort wurde geändert vor 4 Tage, 20 Stunden von maxnomo.
      • #2611
        maxnomo
        Teilnehmer

        Hallo

        habe in den user settings die Zeitzone ändern können. War zu einfach.

        Aber das Hochkomma stört mich immer noch, bzw ich verstehs halt nicht ,warum es erscheint…

        Danke

    • #2612
      David
      Verwalter

      Mach Mal bitte einen Screenshot deiner Config

       

    • #2615
      maxnomo
      Teilnehmer

      Hier , s.u.

      Anhänge:
    • #2628
      David
      Verwalter

      Du startest deine Sonnenaufgang und Sonnenuntergang value Templates jeweils mit einem hoch Komma, aber schliesst sie nicht damit ab.

       

      Nimm es am Anfang der Zeile einfach raus. Dann sollte alles passen.

       

      Oder, du änderst die Syntax auf Single Line (entfernst das > – Zeichen) und setzt am Ende noch ein Hochkomma

    • #2634
      Osorkon
      Teilnehmer

      Oder verwende die custom Card „ha-card-weather-conditions“ 😀 Da kannst Du gleich auch neben der Sonnenaufgang/Untergang Zeiten auch die für dich relevante Wetterdaten in einer Karte anzeigen lassen.

      575925EA-3814-4618-AA0B-0B567D97383D

    • #2637
      David
      Verwalter

      Die ist ja nett! Danke

    • #2640
      maxnomo
      Teilnehmer

      @David: genau das war‘, die Hochkommas..

      Danke

Ansicht von 7 Antwort-Themen
  • Du musst angemeldet sein, um auf dieses Thema antworten zu können.